PHP 7.1 has some new and interesting features that you might want to use with Nginx. Currently Ubuntu 17.04 and previous version can only install up to PHP