AbanteCart 1.2.13 Released — Here’s How to Install / Upgrade on Ubuntu 16.04 | 18.04 LTS

AbanteCart, a free and open source eCommerce platform built on the LAMP / LEMP stack has just been updated to version 1.2.13… and this brief tutorial shows students and new users how to install / upgrade on Ubuntu 16.04 | 18.04 LTS servers…

This release comes with improvements, bug fixes, and default extension updates… which may improve your store performance and security… If you haven’t upgraded to this version, you’re encouraged to do so as soon as possible…

Some notable additions to this version are: support for PHP 7.2, improved error handling in response controllers when not found, TinyMCE updated to v4.7.10 and many more…

For a complete list of bugs fixed and improvement added, please check it changelog page

Below are some of the features that are added…

Core:

  • Testing with PHP 7.2 and warnings resolution
  • ARouter fix related to \0 at the end of route and further improvement
  • cache file driver minor fix
  • sql fix in store_description table
  • improved error handling in response controllers when not found
  • Fix for duplicating images on import
  • PHP files reformating to PSR

Admin:

  • TinyMCE updated to v4.7.10
  • improve SQL error handling in product creation
  • Added save to store ID in case of missing category
  • extension settings saving improvement
  • task modal js-fix related to attempts on fail requests

Storefront:

  • minor fix of product-controller related to “rating” html-field
  • Add activation link resend option
  • Add CSS class to BODY tag to identify pages.

Extensions:

  • PayPal Standard and Express Improvment
  • Avatax integration
  • Fixes in CardConnect
  • Stripe payment update
  • Twilio update
  • Neowize terms and conditions link update
  • Update for encryption extension

Extensions:

  • Add SEO data returned to API
  • Fix for latest product API and currency conversion rounding (rare case)

For those who want to learn how to install or Upgrade AbanteCart, the posts below should help….

Option 1: Installing AbanteCart with Apache2 Support

If you want to install AbanteCart on Ubuntu with Apache2 support, please read this post:

Install AbanteCart on Ubuntu 16.04 / 17.10 / 18.04 with Apache2, MariaDB, PHP 7.2 and Let’s Encrypt SSL/TLS Certificates

Option 2: Installing AbanteCart on Ubuntu with Nginx Support

For those who want to setup AbanteCart with Nginx support instead should read the post below:

Setup AbanteCart on Ubuntu 16.04 / 17.10 / 18.04 with Nginx, MariaDB, PHP 7.2 and Let’s Encrypt SSL/TLS Certificates

Option 3: Upgrading AbanteCart

If you already have AbanteCart installed and you wish to upgrade, follow the steps below:

First, you should always backup your site database and content folder prior to upgradeing… To learn how to backup MySQL databases, search on this site for help… After backing up your content, logon to AbanteCart admin portal and you should see an upgrade alert….

upgrade abantecart site

Click the upgrade message and you should see a link to begin the upgrade…

Upgrade for your AbanteCart to new version 1.2.13 is now available. Please click –> this link to start the upgrade. About this release: New AbanteCart v1.2.13 contains improvements, bug fixes, and default extension updates. IMPORTANT NOTES: 1. Backup your code and Mysql database before you upgrade 2. Do not run upgrades directly on live sites. Try upgrades on test or clone site first.

upgrade AbanteCart

The link should take you to an upgrade page… no worries here, after backing up your site… perform the upgrade directly and hopefully everything should be successful…..

Enjoy!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.